Siebel Installations >  Server requirements for Siebel installation in Solaris

Server requirements for Siebel installation in Solaris

This was required for Siebel 8.1.1.8 with Solaris 10
This shows the checks we need to make on Solaris server before starting the installation.

cat /etc/passwd - check whether users and their group membership are set as requested
This should be decided by you. The minimum would be a login for siebel, oracle and sadmin.

check df -h and compare volume sizes and mounts with the specification.
The only recommendation here is that the server must have a minimum of 4 GB memory for Siebel.

check whether access rights to the directories are set as requested.
User siebel must have full rights to /users/services/siebel
siebeol must also have full rights to all siebel binaries installed (chaeck after installation).

All other users have execute and read rights in folder /services.


Kernel Parameter check

/usr/sbin/ndd -get /dev/tcp <parameter> - check values of tcp* parameters

bash-3.2$ /usr/sbin/ndd -get /dev/tcp tcp_co_min
1500
bash-3.2$ /usr/sbin/ndd -get /dev/tcp tcp_conn_req_max_q
1024
bash-3.2$ /usr/sbin/ndd -get /dev/tcp tcp_conn_req_max_q0
4096

set rlim_fd_max=65536
set rlim_fd_cur=65536
set kernel_cage_enable=1

or change the values in file /etc/systems
cat /etc/system
* Begin - required parameters for SBL
set rlim_fd_max=65536
set rlim_fd_cur=65536
set kernel_cage_enable=1
* End - required parameters for SBL

 

SSH local -> server via SSH client
SSH server A -> server B


create SSH keys to allow no-password-prompt SSH connect 

ssh-keygen -t rsa
cat .ssh/id_rsa.pub | ssh <target_server> 'cat >> .ssh/authorized_keys'
telnet <target_server> <port>


e.g.
cat .ssh/id_rsa.pub | ssh 10.254.113.75 'cat >> .ssh/authorized_keys'
in 122
ssh-keygen -t rsa
cat .ssh/id_rsa.pub | ssh server1 'cat >> .ssh/authorized_keys'
cat .ssh/id_rsa.pub | ssh server2 'cat >> .ssh/authorized_keys'
cat .ssh/id_rsa.pub | ssh server3 'cat >> .ssh/authorized_keys'

 

mv $HOME/local.profile .profile
edit $HOME/.profile - add env variables incl. PATH
mv $HOME/local.cshrc .cshrc
mv $HOME/local.login .login
create and edit $HOME/.bashrc - add aliases and shell prompt

 

 

check /etc/cron.d/cron.allow and /etc/cron.d/cron.deny
desired user must be listed in cron.allow and must not be listed in cron.deny file


set crontab editor by adding
env VISUAL=vi
export VISUAL

into .profile file

 

An example of .profile file is

VISUAL=vi
export VISUAL

.bashrc file

PS1_1="\\u@\\h:\\w> "
PS1_2="\\u@\\h:\\W> "

alias l='ls -la'
alias ll='ls -la'
alias lt='ls -lAtr'
alias c='clear'
alias ps_1='export PS1=$PS1_1'
alias ps_2='export PS1=$PS1_2'
alias ..='cd ..'
alias ...='cd ../..'
alias cd..='cd ..'
alias gr30='find . -ls | sort -k 7n | tail -30'
alias hi=history

alias pu='ps -ef | grep siebel | grep -v grep | sort -k8 ; ps -ef | grep siebel | grep -v grep | wc -l'
alias psg='ps -ef | grep sieb'
alias pss='/usr/ucb/ps -auxww|grep siebel'

 

add sensible line into crontab 

crontab -e
check crontab entry : crontab -l
run simple script via crontab and check its functionality
remove the entry from crontab : crontab -r

Issue tnsping command, version should appear if client is installed

if the client is installed, add following into $HOME/.profile :

ORACLE_HOME=<client_installation_path>
export ORACLE_HOME
PATH=$PATH:$ORACLE_HOME/bin
export PATH

Issue coreadm command and check the values

global core file pattern: /siebelfs/coredump/core_%n_%f_%u_%g_%t_%p
global core file content: default
init core file pattern: /siebelfs/coredump/core_%n_%f_%u_%g_%t_%p
init core file content: default
global core dumps: enabled
per-process core dumps: disabled
global setid core dumps: enabled
per-process setid core dumps: disabled
global core dump logging: enabled

Binaries that should exist in Solaris

scdpm
scdsbuilder
scdsconfig
scdscreate
sceventmib
scgdevs
scha_check_app_user
scha_cluster_get
scinstall
scnas
scnasdir
scprivipadm

Cluster
If server is part of a cluster, there should be a /global directory

Ports
You should make a list of ports used by Database, siebel , TCP/IP and Webservers. All these ports should be freed
and not blocke by firewall.

Default Ports for example are 2320 and 2321 for siebel. 80 and or 8080 for webserver.
Database ports need to be vonfigured by the DBA. TCP/IP and SSH ports by default are
20,21 and 443 for ssl.